Planet

20 Mars 2008 à 18:54

Ubuntu me surprend toujours :) via erwan.me

Ubuntu me surprend toujours dans le bon sens au grè des nouvelles versions. Même après plusieurs mois sous Gutsy, je ne m'étais pas encore rendu compte qu'Ubuntu gérait de mieux en mieux ma souris sans fils "atypique" et surtout l'énergie. Peut être vous vous souvenez de ma légère galère avec cette superbe souris. A l'époque, j'avais même fait un script pour m'indiquer un niveau faible des piles. C'était il y a deux ans... Déjà... Je ne compile plus lmpcm_usb (le module de ma souris) depuis des lustres et cette fonctionnalité est certainement présente depuis Edgy ou Feisty.
Car aujourd'hui, j'ai eu une bonne surprise : pile faible

(Enfin, presque, la traduction est tronquée.[1])

Notes

[1] D'ailleurs, comment fait-on pour ajouter ce bug ? S'il n'y est pas déjà. Ou corrigé le texte dans Rosetta ? Je fouille mais ne trouve pas de mode opératoire pour ce genre de bug.

BlogORabais, le blog qui vous annonce les nouveautés 2 ans aprés :)

19271525Skype est sorti hier pour Linux dans une nouvelle version ENFIN finale estampillée 2.0.0.63.

A noter quelques petits ajouts mais c'est surtout un nombre assez impressionnant de bugs qui ont été corrigés.

Pour consulter les notes de mises à jour, cliquer ici. Pour télécharger cette nouvelle version de Skype dans sa version Ubuntu, cliquer ici.

Rappelons que la version 2.0 introduit la gestion des appels vidéo, le chat jusqu'à 100 personnes et des conférences audio jusqu'à 9 interlocuteurs.

Réactions à propos de ce billet, questions, problèmes ? N'hésitez pas à poster un message sur le forum du blog.

rarLes archives téléchargées dans les newsgroups binaires ou provenant du monde Windows sont très souvent au format RAR. Ce dernier n'étant pas libre, il n'est pas reconnu d'origine par Ubuntu. Pour permettre au gestionnaire d'archives (File Roller) de décompresser les archives RAR, voici comment procéder :

1. Dans le menu "Système", choisir "Administration" puis "Sources de logiciels"

2. A la rubrique correspondant à l'onglet "Logiciels Ubuntu", cocher "Logiciel soumis au droit d'auteur ou à des restrictions légales (multiverse)"

3. Dans le menu déroulant "Télécharger depuis :" changer "Serveur principal" en "Serveur pour France" puis valider

4. Cliquer sur le bouton "Actualiser" lors de l'apparition du message "Les informations sur les logiciels disponibles sont obsolètes"

5. Dans le menu "Système", choisir "Administration" puis "Gestionnaire de paquets Synaptic"

6. Cliquer sur le bouton "Rechercher" , taper "unrar" (sans les guillemets) puis valider

7. Dans le résultat de recherche, cocher la case à gauche de "unrar" puis cliquer sur le bouton "Appliquer" en haut

Faire de même (étapes 6 et 7) avec "rar" (sans les guillemets) pour ajouter la fonction de compression au format RAR si nécessaire

8. Retourner dans "Sources de logiciels" pour rétablir "Serveur principal" (voir étapes 1, 3 et 4). En effet ce serveur par défaut ne semble pas héberger les paquets "rar" et "unrar" car ces derniers sont originaires de RARlab et donc non libres.

Désormais il suffit de double-cliquer sur une archive RAR pour l'ouvrir avec le gestionnaire d'archives par défaut ou bien de cliquer avec le bouton droit de la souris dessus puis "Extraire ici" pour la décompresser à l'endroit courant ! Bien plus pratique que d'utiliser les autres applications de décompression alternatives en ligne de commandes !

Réactions à propos de ce billet, questions, problèmes ? N'hésitez pas à poster un message sur le forum du blog.

05 Mars 2008 à 21:26

u-classroom : suite du cours vim via U Classroom

La suite du cours Vim donné il y a 10 jours par yannick_lm aura lieu ce vendredi 07 mars à 20H00 (heure française métropolitaine), toujours sur le canal #u-classroom du réseau irc freenode.

Si vous n'avez pas pu suivre la première session, le cours est en ligne.

A vendredi !

Geany est un superbe éditeur de texte, léger et complet, avec coloration syntaxique et à onglet. Je ne me sert pas beaucoup de ses autres multiples fonctions mais je n'ai jamais trouvé un éditeur de code aussi rapide et léger avec la coloration syntaxique.

Depuis que j'ai mon eeePC, je ne pouvais l'utiliser qu'en plein écran étant donner que la fenêtre avait une hauteur minimale, ce qui est assez gênant. Ce bug est a présent résolu mais sur le SVN, donc on va compiler tout ça :

  • la première étape est la compilation d'une libstg_cur 2.7.1 car elle n'est pas disponible dans les dépots de Ubuntu.

nan, je rigolais, je vous ai fait un paquet :) :

Je décline toute responsabilité, c'est un paquet fait avec checkinstall sans les règles de l'art, les dépendances doivent être correct mais rien n'est officiel. Vous voilà prévenu. Ne l'installez que si vous avez réellement besoin d'une fenêtre de geany toute petite sur un tout petit (eee)PC :)

geany svn

Et je suis sûr que la question va venir dans les commentaires : oui, on peut très bien coder un peu sur l'eeePC, le clavier est petit mais on s'habitue très vite. Et pour plus de place, il y a aussi pyroom que j'utilise presque tous les jours maintenant :)

21 Février 2008 à 18:30

Splash Compiz xUbuntu via erwan.me

Voila, je viens de séparer la souris Xfce et le cercle humain bleu de xUbuntu pour en faire deux images utilisables pour le démarrage de Compiz. (oui, c'est pas bien compliqué et j'ai fais ça rapidement)

Pour les utiliser (ou les tester), dans CompizConfig Configuration Manager (ccsm pour les intimes) c'est le plugin "écran d'accueil" dans la catégorie "extra", onglet "image" :

Image de fond (celle qui ondule joliment) : le cercle bleu.
Fichier logo : La souris.

Control + F11 pour admirer la beauté de Compiz :) xubuntu_noMouse xfceMouse

À propos de la licence :

14 Février 2008 à 20:01

Prochaine session : vim via U Classroom

Qui n'est jamais passé par là... Démarrage de vim (généralement par un complet hasard), râleries parce que cet éditeur bizarre n'a pas l'air de marcher (jusqu'à ce qu'on tombe sur la bonne touche, mais sans comprendre ce qui s'est passé), et fermeture violente de console parce qu'impossible de trouver comment sortir de l'éditeur :)

C'est Yannick LM qui sera le professeur pour la session classroom sur vim. Elle se déroulera le vendredi 22 février à 20 heures (heure métropolitaine, 19H00 UTC), sur le canal #u-classroom du réseau irc freenode.

Aucun prérequis n'est nécessaire à ce cours, si ce n'est une installation du logiciel ('sudo apt-get install vim' pour debian et dérivés).

Une fois vim maîtrisé, vous ne verrez plus votre console du même oeil ! Et vous pourrez profiter de la seconde session (dont la date sera donnée ultérieurement).

A bientôt sur #u-classroom !

14 Février 2008 à 00:27

Mise à jour noyau sur une dedibox via ~tigrou/pwet.fr

Plusieurs bugs de sécurté importants ont été découverts dans le noyau Linux, en particulier le bug CVE-2008-0600 permet à un utilisateur local d'obtenir un shell avec les droits root assez simplement. Même sans utilisateurs locaux, la faille peut devenir exploitable via une autre faille d'une application web par exemple, même si ça devient beaucoup plus compliqué.

La seule solution est de mettre à jour son noyau. J'ai réalisé cette opération tout à l'heure sauf que je ne connaissais pas encore le petit détail mentionné dans ce billet et rappelé dans un topic du forum Ubuntu-fr ce qui m'a donné un bon gros coup de stress :-) et une bonne heure de pwet.fr HS :-/

Bref, sur les dedibox utilisant le noyau fournit par Dedibox la manipulation est simple. Une fois le kernel spécifique installé, il faut indiquer l'emplacement de la racine du système avec l'ancienne syntaxe (type /dev/sdXY) au lieu des UUID. Sinon la machine ne reboote pas. Heureusement, les dedibox ont un système de rescue bien pratique qui permet de se sortir de ce genre de situation. Concrètement, avant pour chaque choix dans le fichier /boot/grub/menu.lst, j'avais quelque chose comme :

title Ubuntu, kernel 2.6.24.2 root (hd0,0) kernel /vmlinuz-2.6.24.2 root=UUID=238ddcbc-cb7e-4023-a48e-932d874b5ef0 ro quiet splash quiet savedefault

que j'ai remplacé par

title Ubuntu, kernel 2.6.24.2 root (hd0,0) kernel /vmlinuz-2.6.24.2 root=/dev/sda3 ro quiet splash quiet savedefault

Évidemment, /dev/sdaY est spécifique à l'organisation de la machine, il s'agit du numéro de la partition root du système. Il semble qu'avec le partitionnement par défault, il s'agisse de /dev/sda2. Avec le système de rescue de Dedibox, pour déterminer qu'elle est le bon numéro, il faut monter toutes les partitions du système et trouver le numéro de celle qui contient toute l'arborescence ( /bin, /usr, /lib, ...).

SDcardJe viens de mettre à jour le portable de ma dulcinée de dapper à gutsy. Il est resté si longtemps dans une vieille version parce qu'elle l'utilisait de manière critique et selon l'adage si ce n'est pas cassé, pas besoin de le réparer !

Seulement, voila, la mise à jour à cassé le fonctionnement du lecteur de carte SD qui en l'occurrence ne marche plus du tout :( C'est un problème connu avec les lecteurs de carte de Texas[1]. Dans la doc ubuntu-fr, il est marqué comme ne fonctionnant pas depuis feisty et l'on trouve de nombreux bugs reportés dans Launchpad : 53923, 18706, 180076 ou encore 137686[2].

Parmi tous ces bugs de nombreux contournements sont proposés, comme par exemple décharger/charger les modules en boucle jusqu'à ce que le lecteur soit reconnu ! Bref rien de satisfaisant, ni même de fonctionnel chez moi :( . Mais la vérité est ailleurs, nos amis de Mandriva ont aussi le problème et ont trouvé une solution !

Et effectivement, ça marche ! Un patch à appliquer, un module à recompiler et voila, le lecteur fonctionne parfaitement ! Voici en quelques points la procédure à appliquer :

  • préparer la compilation d'un noyau comme indiqué dans la doc
  • avant de lancer la compilation, appliquer le patch fournit par Mandriva soit avec un petit patch -p1 < DB35_mmc_power_up_delay.patch soit en modifiant directement les 2 lignes concernées dans drivers/mmc/core/mmc_core.c[3]
  • compiler, perso j'ai recompilé tout le noyau, mais on devrait pouvoir se contenter des modules, profitez en comme moi pour aller à la plage ;)
  • enfin il suffit de sauvegarder l'ancien module (/lib/modules/2.6.22-14-generic/kernel/drivers/mmc/core/mmc_core.ko) et de le remplacer par votre nouveau
  • et voila, un reboot[4] plus tard tout est rentré dans l'ordre \o/

Pour conclure, ce n'est qu'une solution temporaire, à la prochaine maj officielle des modules, il faudra recommencer, mais j'ai bon espoir que le problème étant corrigé, ce sera inclus dans celle-ci.

Notes

[1] PCI id: 104c:803b

[2] Notez bien ce dernier

[3] c'est ce que j'ai fait

[4] pas compris pourquoi il fallait rebooter sur ce coup, rmmod/modprobe n'ont pas suffit

10 Février 2008 à 09:04

Petit rappel via FF-IRC

À la vue du dernier billet du Planet Ubuntu-fr.org, il me semblait bon de vous rappeler, notamment à cause du spam et de la confusion que cela a pu engendrer sur notre canal IRC #ubuntu-fr, que le seul forum francophone officiel (faisant parti de la LoCoTeam ubuntu-fr.org) est toujours (et a toujours été) forum.ubuntu-fr.org.

L'autre forum, dont je ne citerais pas l'URL (il suffit d'aller voir le billet cité) afin de ne pas augmenter la confusion, n'est en rien lié à ubuntu-fr.org, même si l'adresse de celui-ci a été diffusée sur le Planet, qui est une agrégation de blogs non-liés à ubuntu-fr.org. Il est sous la totale responsabilité et direction de l'auteur du billet.

Bref, un simple rappel, rien de trop grave pour le moment sur le front.

L'équipe de modération IRC

Pages